Questo Forum utilizza Cookies tecnici per poter funzionare
Questo forum fa uso di cookies tecnici per poter memorizzare le tue informazioni di login se sei un utente registrato, e la tua ultima visita se non sei registrato. I Cookies sono piccoli testi memorizzati sul tuo computer; i cookies inviati da questo forum sono utilizzati soltanto su questo sito, per il suo normale funzionamento e per consentirti la partecipazione al forum stesso e non sono in alcun modo pericolosi per la tua privacy. I Cookies di questo forum tengono traccia anche delle discussioni che hai già letto, per permetterti di individuare visivamente se ci sono nuovi messaggi. Per favore, conferma se accetti o rifiuti questi cookies.

Un cookie sarà memorizzato nel tuo browser, indipendentemente dalla tua scelta, al fine di impedire che questo messaggio ti venga mostrato nuovamente. Potrai cambiare in ogni momento le tue scelte in merito alle impostazioni dei cookies utilizzando il link in fondo alla pagina.


LISTA AGGIORNATA DEI RIVENDITORI AUTORIZZATI COCKTAIL AUDIO
Attenzione: I prodotti acquistati al di fuori del canale ufficiale NON potranno accedere all'Area Riservata del Club CocktailAudio Italia né ai servizi Forum/Chat/Ticket.
REGISTRA IL TUO COCKTAIL AUDIO per poter accedere all'AREA RISERVATA DEL CLUB COCKTAILAUDIO ITALIA.

Cuffie Meze


Puoi seguire le nostre dirette Live anche su YouTube e su Facebook

Valutazione discussione:
  • 0 voto(i) - 0 media
  • 1
  • 2
  • 3
  • 4
  • 5
webgui lentissima...
#1
Ho avuto la (pessima) idea di aggiornare l'X10 con la nuova versione di firmware.
Poichè mi piaceva la webgui precedente (con la nuova non sono riuscito a impostare la modalità di visualizzazione copertine grandi, webgui lentissima e non funzionante) ho reistallato la precedente versione del firmware (R1793).
Prima di installare la nuova R1805, funzionava tutto a meraviglia, poi da questo punto in poi la webgui non mi funziona più a dovere (ogni pagina dopo 1,2 minuti e funzionalità di questa non attive, anche dopo aver reinstallato la R1793)
Su quale parametro devo intervenire...? (...se di questo si tratta...)
Normalmente usavo l'indirizzo: 'http://192.168.1.220/nov/nov_DBTool/index.php?m=al' e andava tutto bene.
Adesso se digito solo l'ip dell'X10 parte subito la maschera verde con la scelta delle 2 versioni senza problemi... ma quando scelgo una delle 2 ho il blocco...
A qualcuno è già successo?
Sono veramente demoralizzato...le ho provate tutte, il DB è OK, ho reinstallato la webgui, ho rimesso le impostazioni di fabbrica..ho ricontrollato tutti i parametri, il PC e l'X10 sono nello stesso gruppo di lavoro (WORKGROUP) ecc..
Dimenticavo: con il file manager di windows 7 vedo benissimo e rapidamente le directory dell'X10...
Staff
#2
Non ci risulta assolutamente che la WebGUI sia lenta, tanto meno lentissima, tutt'altro...la nuova versione è velocissima e letteralmente vola su smartphone e tablet e su PC con browser aggiornati (usare Chrome o Firefox, NO Internet Explorer).

Ogni volta che si cambia Firmware BISOGNA reinstallare ANCHE la interfaccia Web. Lo abbiamo scritte decine e decine di volte. Quindi, se hai fatto un downgrade del firmware, devi fare il reset alle impostazioni di fabbrica, riconfigurare le opzioni di rete e reinstallare anche la webGUI, .
Francesco

Cocktail Audio è anche su Facebook: Seguici e clicca su "MI PIACE"!!! - https://www.facebook.com/cocktailaudio - Distribuito in esclusiva in Italia da POLARIS AUDIO SRL: https://www.polarisaudio.it Sei Cliente CocktailAUDIO? Inviaci una Tua Recensione! Leggi le recensioni sul CocktailAUDIO: i Feedback su CocktailAUDIO. Per aggiungermi su Facebook Clicca qui.
#3
Francesco,
anche perchè mi occupo di informatica dal 1982, sono abbastanza allenato alle procedure di 'problem solving', tanto allenato che per due giorni, dopo aver messo le mani sull'X10 (reset, riconfigurazione e installazione della webgui più volte) ho lavorato sulla configurazione del PC, riconfigurando uno alla volta tutti tutti quei parametri (sopratutto sulla scheda di rete, sui privilegi delle utenze di dominio, sull'autotuning del TCP, sulla risoluzione DNS) che potenzialmente potevano rallentare il riconoscimento dei 2 device in rete locale...

Nonostante l'avessi fatto diverse volte, ho spento per l'ennesima volta l'X10 dall'interruttore posteriore, l'ho riacceso e..... miracolo... la WEBGUI E' RITORNATA VELOCE.

Quindi, o in maniera 'random' l'X10 ha deciso di collaborare, oppure mancava quell'ultimo passaggio a chissà quale modifica effettuata...

Per mia curiosità: la nuova webgui permette la visualizzazione per copertine (non quella tabellare, quella con 4 copertine grandi per riga), come possibile sulla versione 0.9.6.7b?
Sinceramente non ci ho perso molto tempo, e non essendoci riuscito è stato questo il motivo del downgrade...
Sto pensando di mettere mano al codice PHP per riabilitarmi questa visualizzazione...

Grazie comunque.
Mauro.
Staff
#4
Ciao Mauro, non esiste più quella visualizzazione, ora è stata scelta quella di tipo infinite scroll con aggiornamento continuo della visualizzazione.

Il codice php della ultima webgui (aggiungo purtroppo) è stato criptato con Ioncube, pertanto non è più editabile liberamente da chi ne aveva capacità, il tempo e la voglia di farlo. Un vero peccato, ma sono scelte su cui non ci è possibile intervenire. Sarebbe piaciuto molto anche a me che fosse rimasto visibile il sorgente.
Francesco

Cocktail Audio è anche su Facebook: Seguici e clicca su "MI PIACE"!!! - https://www.facebook.com/cocktailaudio - Distribuito in esclusiva in Italia da POLARIS AUDIO SRL: https://www.polarisaudio.it Sei Cliente CocktailAUDIO? Inviaci una Tua Recensione! Leggi le recensioni sul CocktailAUDIO: i Feedback su CocktailAUDIO. Per aggiungermi su Facebook Clicca qui.
#5
... ma se esiste una versione di firmware con la webgui non criptata si potrebbe installare il firmware che la contiene, scaricarla su pc, lavorarla, riallineare l'X10 con la versione di firmware corrente, sostituire la webgui corrente con quella lavorata... e si spera dovrebbe funzionare tutto!
E' ancora disponibile una versione di firmware, o meglio l'ultima, con il codice PHP non offuscato?
Se si, e non si infrange nessun tipo di copyright, ci si potrebbe provare...

PS.: se ricordo bene script PHP criptati con Ioncube sono facilmente decriptabili con numerose app in rete... ma penso che questa operazione sia vietata...
Staff
#6
Forse sulla R1793 non era ancora offuscata. Ma il copyright c'è naturalmente, perchè la WebGUI non è mai stata rilasciata in licenza open source, altrimenti non l'avrebbero criptata successivamente.
Naturalmente per uso privato e personale, puoi fare tutte le prove e modifiche che vuoi con la precedente versione.
Francesco

Cocktail Audio è anche su Facebook: Seguici e clicca su "MI PIACE"!!! - https://www.facebook.com/cocktailaudio - Distribuito in esclusiva in Italia da POLARIS AUDIO SRL: https://www.polarisaudio.it Sei Cliente CocktailAUDIO? Inviaci una Tua Recensione! Leggi le recensioni sul CocktailAUDIO: i Feedback su CocktailAUDIO. Per aggiungermi su Facebook Clicca qui.




Utenti che stanno guardando questa discussione: 1 Ospite(i)